Forum QuakeWorld.pl - Forum Strona Główna QuakeWorld.pl - Forum
Forum dyskusyjne polskiej sceny QuakeWorld
 
 FAQFAQ   SzukajSzukaj   UżytkownicyUżytkownicy   GrupyGrupy   RejestracjaRejestracja 
 ProfilProfil   Zaloguj się, by sprawdzić wiadomościZaloguj się, by sprawdzić wiadomości   ZalogujZaloguj 

Problem z libXxf86dga.so.1/libxxf86dga1

 
Napisz nowy temat   Ten temat jest zablokowany bez możliwości zmiany postów lub pisania odpowiedzi    Forum QuakeWorld.pl - Forum Strona Główna -> Linux
Zobacz poprzedni temat :: Zobacz następny temat  
Autor Wiadomość
fluartity
Moderator
Moderator


Dołączył: 26 Kwi 2006
Posty: 989
Skąd: Trzebinia

PostWysłany: Sro Mar 09, 2011 5:44 pm    Temat postu: Problem z libXxf86dga.so.1/libxxf86dga1 Odpowiedz z cytatem

Witam Unix`owców!
Przy próbie uruchomienia aplikacji *.glx :
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ ./ezquake-gl-3a20643.glx
./ezquake-gl-3a20643.glx: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory


Ciekawostka:
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ sudo apt-get install libxxf86dga1
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
libxxf86dga1 jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.


Specyfikacja:
System: Ubuntu 10.10 64bit
NVIDIA Driver Version: 260.19.06

Problem mnie dręczy od kilku dni, oczywiście wujek google nie zdołał rozwiać moich wątpliwości a tym bardziej ukierunkować mnie na jakąś nową alternatywę.

Z góry thx za zaangażowanie Smuteczek

EDIT: oczywiście biblioteki znajdują się :
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ locate libXxf86dga
/usr/lib/libXxf86dga.a
/usr/lib/libXxf86dga.so
/usr/lib/libXxf86dga.so.1
/usr/lib/libXxf86dga.so.1.0.0
/usr/lib/debug/usr/lib/libXxf86dga.so.1.0.0

_________________
[ http://dc.quakeworld.pl Demolition Crew: Member ]
[ http://quakeworld.pl Administrator ]
[ http://forum.quakeworld.pl Moderator ]
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
Chmielu
Bumstik4Life!
Bumstik4Life!


Dołączył: 06 Kwi 2005
Posty: 230
Skąd: Jaworzno

PostWysłany: Sro Mar 09, 2011 5:52 pm    Temat postu: Odpowiedz z cytatem

u mnie tez tak:(
_________________
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
plast
Mistrz Polski


Dołączył: 15 Mar 2005
Posty: 2615

PostWysłany: Sro Mar 09, 2011 5:59 pm    Temat postu: Odpowiedz z cytatem

glxgears dziala?
_________________
Death Dealers Clan
http://dealers.quakeworld.pl
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
Fausto
Biorę przyQUAD
Biorę przyQUAD


Dołączył: 23 Mar 2005
Posty: 907
Skąd: Warszawa

PostWysłany: Sro Mar 09, 2011 6:28 pm    Temat postu: Odpowiedz z cytatem

Moglby ktos zmienic styl tych kawalkow kodu? Sa w chuj nieczytelne.

Fluar:

wklej mi tu ldd ezquake-gl-3a20643.glx
_________________
These are my glasses.
There are many like them, but these ones are MINE.
My glasses are my best friends. They are my life.
I must master them as I must master my life.
My glasses without me are useless. Without my glasses, I am useless.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
fluartity
Moderator
Moderator


Dołączył: 26 Kwi 2006
Posty: 989
Skąd: Trzebinia

PostWysłany: Sro Mar 09, 2011 6:30 pm    Temat postu: Odpowiedz z cytatem

plast napisał:
glxgears dziala?


Kod:
Program glxgears nie jest obecnie zainstalowany.  Można go zainstalować wpisując:
sudo apt-get install mesa-utils


Do instalowałem i działa owa aplikacja > "glxgears"

ale *.glx dalej:
Kod:

fluartity@fluartity-pc:~/Pulpit/Quake$ ./ezquake-gl-3a20643.glx
./ezquake-gl-3a20643.glx: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory



EDIT: for Faustov
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ ldd ezquake-gl-3a20643.glx
   linux-gate.so.1 =>  (0xf777f000)
   libm.so.6 => /lib32/libm.so.6 (0xf7739000)
   libpthread.so.0 => /lib32/libpthread.so.0 (0xf7720000)
   librt.so.1 => /lib32/librt.so.1 (0xf7716000)
   libGL.so.1 => /usr/lib32/nvidia-current/libGL.so.1 (0xf764d000)
   libXxf86dga.so.1 => not found
   libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf7647000)
   libXpm.so.4 => /usr/lib32/libXpm.so.4 (0xf7636000)
   libc.so.6 => /lib32/libc.so.6 (0xf74da000)
   libX11.so.6 => /usr/lib32/libX11.so.6 (0xf73bd000)
   libdl.so.2 => /lib32/libdl.so.2 (0xf73b9000)
   /lib/ld-linux.so.2 (0xf7780000)
   libnvidia-tls.so.260.19.06 => /usr/lib32/nvidia-current/tls/libnvidia-tls.so.260.19.06 (0xf73b7000)
   libnvidia-glcore.so.260.19.06 => /usr/lib32/nvidia-current/libnvidia-glcore.so.260.19.06 (0xf5d1a000)
   libXext.so.6 => /usr/lib32/libXext.so.6 (0xf5d09000)
   libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf5cef000)
   libXau.so.6 => /usr/lib32/libXau.so.6 (0xf5ceb000)
   libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf5ce5000)


libXxf86dga.so.1 => not found << no dobra to teraz gdzie to przenieść/podlinkować Uśmiech...

EDIT #2:
Kod:
fluartity@fluartity-pc:/usr/lib$ sudo ls -l /usr/lib/libXxf86dga.so.1*
lrwxrwxrwx 1 root root    29 2011-03-09 19:39 /usr/lib/libXxf86dga.so.1 -> /usr/lib/libXxf86dga.so.1.0.0
-rw-r--r-- 1 root root 27000 2010-01-22 13:10 /usr/lib/libXxf86dga.so.1.0.0
fluartity@fluartity-pc:/usr/lib$ cd ..
fluartity@fluartity-pc:/usr$ cd lib64
fluartity@fluartity-pc:/usr/lib64$ sudo ls -l /usr/lib64/libXxf86dga.so.1*
lrwxrwxrwx 1 root root    29 2011-03-09 19:39 /usr/lib64/libXxf86dga.so.1 -> /usr/lib/libXxf86dga.so.1.0.0
-rw-r--r-- 1 root root 27000 2010-01-22 13:10 /usr/lib64/libXxf86dga.so.1.0.0


... lib`y są i teraz pytanie zostaje dalej takie same

EDIT #3:
Reinstalowałem paczke:

Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ ./ezquake-gl-3a20643.glx
./ezquake-gl-3a20643.glx: error while loading shared libraries: libXxf86dga.so.1: wrong ELF class: ELFCLASS64

_________________
[ http://dc.quakeworld.pl Demolition Crew: Member ]
[ http://quakeworld.pl Administrator ]
[ http://forum.quakeworld.pl Moderator ]
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
plast
Mistrz Polski


Dołączył: 15 Mar 2005
Posty: 2615

PostWysłany: Sro Mar 09, 2011 11:36 pm    Temat postu: Odpowiedz z cytatem

wrong elf class to zazwyczaj blad zwiazany z tym, ze odpalasz kod nieprzystosowany do danej architektury, np. masz system 64bit a chcesz uzywac biblioteki 32bit

nie uzywam ubuntu, ale sprobuj zainstalowac pakiety ia32-libs i pochodne (ia32-libs-dev, ia32-libs-gtk) i zobacz czy to cos zmieni, jesli nie to poszukaj tego pliku libXxf86dga.so u siebie w repozytoriach, w ten sposob:

apt-get install apt-file
apt-file update
apt-file search libXxf86dga.so

u mnie w debianie pokazuje, ze jest w tych pakietach: libxxf86dga-dev i libxxf86dga1 - zobacz czy masz to zainstalowane

to w polaczeniu z ia32libs + poprawnymi sterami + dowiazaniami gdzie trzeba powinno cos dac, ale generalnie jesli masz cos bardziej namieszane to moze byc ciezko

ogolnie to caly urok ubuntu Mruga 2
_________________
Death Dealers Clan
http://dealers.quakeworld.pl
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
Fausto
Biorę przyQUAD
Biorę przyQUAD


Dołączył: 23 Mar 2005
Posty: 907
Skąd: Warszawa

PostWysłany: Czw Mar 10, 2011 11:42 am    Temat postu: Odpowiedz z cytatem

oba problemy wynikaja z tego, ze masz system x64 a binarka ezq x86, wiec powinienes uciac sobie palec, jak pobozny czlowiek ktory popelnia blad i zmusza milion ludzi do wytezonej pracy!

Napraw i ciesz sie, ze bog IT nie porazil Cie piorunem do tej pory za te impertynencje! Mruga 2
_________________
These are my glasses.
There are many like them, but these ones are MINE.
My glasses are my best friends. They are my life.
I must master them as I must master my life.
My glasses without me are useless. Without my glasses, I am useless.
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Odwiedź stronę autora
fluartity
Moderator
Moderator


Dołączył: 26 Kwi 2006
Posty: 989
Skąd: Trzebinia

PostWysłany: Czw Mar 10, 2011 1:22 pm    Temat postu: Odpowiedz z cytatem

plast napisał:
wrong elf class to zazwyczaj blad zwiazany z tym, ze odpalasz kod nieprzystosowany do danej architektury, np. masz system 64bit a chcesz uzywac biblioteki 32bit

nie uzywam ubuntu, ale sprobuj zainstalowac pakiety ia32-libs i pochodne (ia32-libs-dev, ia32-libs-gtk) i zobacz czy to cos zmieni, jesli nie to poszukaj tego pliku libXxf86dga.so u siebie w repozytoriach, w ten sposob:

apt-get install apt-file
apt-file update
apt-file search libXxf86dga.so

u mnie w debianie pokazuje, ze jest w tych pakietach: libxxf86dga-dev i libxxf86dga1 - zobacz czy masz to zainstalowane

to w polaczeniu z ia32libs + poprawnymi sterami + dowiazaniami gdzie trzeba powinno cos dac, ale generalnie jesli masz cos bardziej namieszane to moze byc ciezko

ogolnie to caly urok ubuntu Mruga 2

Kod:

fluartity@fluartity-pc:~/Pulpit/Quake$ apt-file search libXxf86dga.so
libxxf86dga-dev: /usr/lib/libXxf86dga.so
libxxf86dga1: /usr/lib/libXxf86dga.so.1
libxxf86dga1: /usr/lib/libXxf86dga.so.1.0.0
libxxf86dga1-dbg: /usr/lib/debug/usr/lib/libXxf86dga.so.1.0.0



ia32-libs zainstalowany ia32-libs-dev i ia32-libs-gtk są zastąpione w danej wersji ubuntu takimi pakietami jak:
lib32z1-dev i lib32bz2-dev
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ sudo apt-get install ia32-libs-dev
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet ia32-libs-dev nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  ia32-libs lib32z1-dev lib32bz2-dev

E: Package 'ia32-libs-dev' has no installation candidate



Po instalacji danych paczek jest ten sam błąd ale widzę że dalej nie może skojarzyć powiązania do : libXxf86dga.so.1 => not found (jak to zmienić?)


Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ ldd ezquake-gl-3a20643.glx
   linux-gate.so.1 =>  (0xf7787000)
   libm.so.6 => /lib32/libm.so.6 (0xf7741000)
   libpthread.so.0 => /lib32/libpthread.so.0 (0xf7728000)
   librt.so.1 => /lib32/librt.so.1 (0xf771e000)
   libGL.so.1 => /usr/lib32/nvidia-current/libGL.so.1 (0xf7655000)
   libXxf86dga.so.1 => not found
   libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf764f000)
   libXpm.so.4 => /usr/lib32/libXpm.so.4 (0xf763e000)
   libc.so.6 => /lib32/libc.so.6 (0xf74e2000)
   libX11.so.6 => /usr/lib32/libX11.so.6 (0xf73c5000)
   libdl.so.2 => /lib32/libdl.so.2 (0xf73c1000)
   /lib/ld-linux.so.2 (0xf7788000)
   libnvidia-tls.so.260.19.06 => /usr/lib32/nvidia-current/tls/libnvidia-tls.so.260.19.06 (0xf73bf000)
   libnvidia-glcore.so.260.19.06 => /usr/lib32/nvidia-current/libnvidia-glcore.so.260.19.06 (0xf5d22000)
   libXext.so.6 => /usr/lib32/libXext.so.6 (0xf5d11000)
   libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf5cf7000)
   libXau.so.6 => /usr/lib32/libXau.so.6 (0xf5cf3000)
   libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf5ced000)


Chyba że nie da się podać mu prawidłowej ścieżki ?

Fausto napisał:
oba problemy wynikaja z tego, ze masz system x64 a binarka ezq x86, wiec powinienes uciac sobie palec, jak pobozny czlowiek ktory popelnia blad i zmusza milion ludzi do wytezonej pracy!

Napraw i ciesz sie, ze bog IT nie porazil Cie piorunem do tej pory za te impertynencje! Mruga 2


xD

Z góry miśki thx za angaż tak to bym nie ruszył z miejsca!

EDIT: pobrałem z bólem inną wersje ezq tym razem 64bit
Kod:
fluartity@fluartity-pc:~/Pulpit/Quake$ ./ezquake-gl.glx
Error: Couldn't load gfx/palette.lmp

? Uśmiech...
a paki są przecież w dobrym miejscu z tego co czytam na ezq manual */id1/pak0.pak | */id1/pak1.pak
_________________
[ http://dc.quakeworld.pl Demolition Crew: Member ]
[ http://quakeworld.pl Administrator ]
[ http://forum.quakeworld.pl Moderator ]
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
plast
Mistrz Polski


Dołączył: 15 Mar 2005
Posty: 2615

PostWysłany: Czw Mar 10, 2011 2:49 pm    Temat postu: Odpowiedz z cytatem

sprawdz uprawnienia, generalnie na probe mozesz dac wszystkiemu chmod 777 to wykluczysz, ze to problem uprawnien jesli dalej nie bedzie dzialac
_________________
Death Dealers Clan
http://dealers.quakeworld.pl
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
fluartity
Moderator
Moderator


Dołączył: 26 Kwi 2006
Posty: 989
Skąd: Trzebinia

PostWysłany: Czw Mar 10, 2011 2:50 pm    Temat postu: Odpowiedz z cytatem

zmieniłem nazwę Id1 na id1 i "bangla" teraz tylko pojawił się problem że mam zbyt dużo "stringów" w cfg ale to chyba ogarnę Uśmiech... temat uważam za zamknięty Uśmiech... thx z góry Faustov i Plast za fatygę! (zawsze to się człowiek czegoś od innych pożytecznego nauczy)!

(zamykam topic)
_________________
[ http://dc.quakeworld.pl Demolition Crew: Member ]
[ http://quakeworld.pl Administrator ]
[ http://forum.quakeworld.pl Moderator ]
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora
Wyświetl posty z ostatnich:   
Napisz nowy temat   Ten temat jest zablokowany bez możliwości zmiany postów lub pisania odpowiedzi    Forum QuakeWorld.pl - Forum Strona Główna -> Linux Wszystkie czasy w strefie CET (Europa)
Strona 1 z 1

 
Skocz do:  
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach


Powered by phpBB © 2001, 2005 phpBB Group